Vamos a ver algunos de los Comandos para routers Cisco más utilizados, y que además nos servirán para nuestras practicas en  Packet Tracer


 


This Photo is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.Creative Commons License

 

 

 

 

Comandos Cisco para propósitos generales

 

  • Habilitar el modo privilegiado:
    1
    
    Router# Enable
  • Configurar (el router) desde la Terminal (teclado):
    1
    
    Router# Config T
  • Renombrar el router :
    1
    
    Router (config)# Hostname MIROUTER
  • Establecer la contraseña cifrada (secreta) para el modo privilegiado como «class»:
    1
    
    MIROUTER(config)# Enable Secret Class
  • Establecer la contraseña  de texto del modo Usuario:
    1
    
    MIROUTER(config)# Enable Password Cisco
  • Desactivar la busqueda DNS:
    1
    
    MIROUTER(config)# No ip domain lookup
  • Seleccionar la interfaz E0:
    1
    
    MIROUTER(config)# Interface Ethernet 
  • Suministrar una descripción:
    1
    
    MIROUTER(config-if)# Descripción
  • Visualizar las últimas 10 líneas de comandos en el búfer de historial:
    1
    
    show history
  • Verificar el software y el hardware del router:
    1
    
    Show version
  • Reiniciar el router (guardando previamente la configuración):
    1
    
    Router# Reload
  • Establecer el tamaño del búfer de historial en x lineas:
    1
    
    terminal history size 70
  • Desactivar el historial de comandos:
    1
    
    terminal no history
  • Activar los Logs del sistema operativo en la Consola:
    1
    
    Router1# Terminal monitor
  • Mostrar la tabla MAC:
    1
    
    show mac-address-table
  • Encriptar las contraseñas almacenadas:
    1
    
    service password-encryption
  • Mostrar estado de las interfaces del router:
    1
    
    Router> show ip interface nombreinterfaz
  • Mostrar información de los vecinos:
    1
    
    Router1# show cdp neighbors detail
  • Inhabilitar cdp:
    1
    
    Router1(config)# no cdp run
  • Habilitar interfaces:
    1
    
    Router1(config-if)# no shutdown
  • Encriptacion de contraseña:
    1
    
    Router1(config)# enable password 123456
  • Guardar la configuracion del router:
    1
    
    Router1# copy running-config startup-config
  • Configuracion NVRAM:
    1
    
    show startup-config
  • Mostrar la configuración actual almacenada en la RAM del router:
    1
    
    Router1# show running-config
  • Mostrar protocolos:
    1
    
    Router1# show ip protocols
  • Borrar la configuración de inicio:
    1
    
    Router1# erase startup config
  • Configurar una descripción para una interfaz, para ayudar a documentar la red:
    1
    
    Router1(config-if)# description

 

 

Comandos CISCO de edición y operaciones básicas

 

  • Entrar al modo privilegiado:
    1
    
    enable
  • Volver al modo de usuario desde el modo privilegiado:
    1
    
    disable
  • Cerrar sesión o salir:
    1
    
    exit router
  • Volver a mostrar el último comando:
    1
    
    flecha hacia arriba o <Ctrl-P>
  • Volver a mostrar el siguiente comando:
    1
    
    flecha hacia abajo o <Ctrl-N>
  • Suspender o abortar:
    1
    
    <Mayús> y <Ctrl> y 6 y luego x
  • Refrescar la salida por pantalla:
    1
    
    <Ctrl-R>
  • Completar el comando ingresado parcialmente:
    1
    
    <Tab> (tecla Tabulador)
  • Desplazarse una palabra hacia atrás:
    1
    
    Esc+B
  • Regresar al modo EXEC Privilegiado estando en cualquier modo de configuración :
    1
    
    Ctrl+Z (o end)
  • Cancelar la ejecución del Dialogo de configuración inicial o Setup :
    1
    
    Ctrl+C

 

 

Comandos Cisco para Copiar

 

  • Copiar la configuración actual de DRAM a NVRAM (memoria no volátil):
    1
    
    copy running-config startup-config
  • Unir la configuración de NVRAM con la de la DRAM:
    1
    
    copy startup-config running-config
  • Copiar la configuración de DRAM a un servidor TFTP:
    1
    
    copy runing-config tftp
  • Unir la configuración TFTP con la configuración actual del router en la DRAM:
    1
    
    copy tftp runing-config
  • Realizar copia de seguridad del sistema operativo IOS en un servidor TFTP:
    1
    
    copy flash tftp
  • Actualizar el IOS (el firmware del sistema operativo) del router desde un servidor TFTP:
    1
    
    copy tftp flash

 

 

Enrutamiento: Comandos generales

 

  • Mostrar Tabla de enrutamiento:
    1
    
    Router1# show ip route
  • Comienza debuging para enrutamiento ip y se muestran los cambios de ip route:
    1
    
    Router1# debug ip routing
  • Deshabilitar debugging:
    1
    
    Router1# undebug all
  • Deshabilitar debuging para ip routing:
    1
    
    Router1# undebug ip routing
  • Habilitar la frecuencia de sincronización para las interfaces SERIAL:
    1
    
    Router1(config-if)# clock rate 64000

 

 

Configurar una dirección IP y la máscara de subred

 

  • 1
    
    Router1(config)# Interface Serial0//
    1
    
    Router1(config-if)#ip address 192.168.3.1 255.255.255.0

 

 

Rutas Estáticas

 

  • Añadir una ruta estatica a la tabla de enrutamiento:
    1
    
    Router1(config) #ip route red mascara-de-subred interfaz
  • Borrar ruta estatica:
    1
    
    Router1(config)# no ip route

 

 

RIPv1

 

  • Habilitar rip:
    1
    
    Router1(config)#router rip
  • Mostrar actualizaciones:
    1
    
    Router1#debug ip rip
  • No enviar actualizaciones RIP desde una interfaz:
    1
    
    Router1(config-router)# passive-interface tipo-interfaz número-interfaz
  • Habilitar rip en todas las interfaces que pertenecen a una red específica:
    1
    
    Router1(config-router)# network dirección-red
  • Desahabilitar rip:
    1
    
    Router1(config)# no router rip
  • Router va a originar información por defecto mediante la propagación de la ruta estática por defecto en la actualización RIP:
    1
    
    Router1(config-router)# default-information originate


  • Redistribuir la ruta estática:
    1
    
    Router1(config-router)# redistribute static
  • Establece una ruta estática en la interfaz null:
    1
    
    Router1(config-router)# ip route 192.168.0.0 255.255.0.0 null interface

 

 

RIPv2

 

  • Difundir ruta estática mediante un protocolo de enrutamiento:
    1
    
    Router1(config)# redistribute static
  • Habilitar v2:
    1
    
    Router1(config-router)# version 2
  • Deshabilitar sumarizacion automática de ruta por defecto en Ripv2:
    1
    
    Router1(config-router)# no auto-summary
  • Cambia el modo de enrutamiento del router a enrutamiento con clase:
    1
    
    Router1(config)# no ip classless

 

 

EIGRP

 

  • Habilitar eigrp: Router1(config)#
    1
    
    router eigrp autonomous-system
  • Habilitar eigrp en un sistema autónomo o as (ha de ser un número entre 1 y 65535. El número ha de ser el mismo en todos los vecinos de EIGRP):
    1
    
    Router1(config)# router eigrp número-de-sistema-autónomo
  • Habilitar eigrp en todas las interfaces de esta red:
    1
    
    Router1(config-router)# network red máscara-subred
  • Comprobar adyacencias con vecinos eigrp:
    1
    
    Router1# show ip eigrp neighbors [tipo-interfaz número-de-sistema-autónomo]
  • Cambiar ancho de banda:
    1
    
    Router1(config-if)#bandwith 256         (se debe elegir el número de kb/s que deseemos)
  • Tabla de topologia eigrp:
    1
    
    Router1# show ip eigrp topology
  • Para mostrar información de depuración sobre EIGRP con métricas sucesor factible (FSM):
    1
    
    Router1# debug eigrp fsm
  • Distribuir rutas estáticas :
    1
    
    Router1(config-router)# redistribute static
  • Cambiar porcentage bandwith:
    1
    
    Router1(config-if)# ip bandwidth-percent eigrp numero-as porcentaje
  • Intervalos de saludo:
    1
    
    Router1(config-if)# ip hello-interval eigrp numero-as segundos
  • Tiempo de hold:
    1
    
    Router1(config-if)# ip hold-time eigrp numero-as segundos
  • Mostrar la información de depuración del proceso eigrp para encontrar errores:
    1
    
    Router1# debug ip eigrp
  • Deshabilitar sumarizacion de ruta por defecto:
    1
    
    Router1(config-router)# no auto-summary
  • Añadir una ruta sumarizada de forma manual a eigrp:
    1
    
    Router1(config-if)# ip summary-address eigrp add ip mascara-red

 

 

OSPF

 

  • Habilitar ospf: Router1(config)#
    1
    
    router ospf id-del-proceso
  • Habilitar paquetes OSPF en interfaces del router cuya dirección de red coincida:
    1
    
    network dirección-de-red máscara-wildcard área-ID-del-área
  • Configurar Id del router:
    1
    
    Router1(config-router)# router-id
  • Verificar y encontrar errores en las relaciones con vecinos OSPF:
    1
    
    Router1# show ip ospf neighbor
  • Mostrar la información de las interfaces relacionadas con OSPF:
    1
    
    Router1# show ip ospf interface
  • Forma rápida de verificar la información de configuración OSPF:
    1
    
    Router1# show ip protocols
  • Mostrar el estado de la base de datos de enlaces OSPF:
    1
    
    Router1# show ip ospf database
  • Mostrar la información OSPF de sumarización sobre todas las interfaces y enlaces compuestos:
    1
    
    Router1# show ip ospf interface
  • Enviar la ruta estática por defecto 0.0.0.0 a los otros routers del área:
    1
    
    Router1(config-router)# default-information originate

 

 

NAT

 

  • Definir un pool de direcciones globales:
    1
    
    Router1(config)# ip nat pool name nombre ip-comienzo ip-final netmask mascara-red
  • Definir una lista de acceso estandar para permitir las direcciones a las que se permitirá la traducción NAT:
    1
    
    Router1(config)# access-list numero-lista-acceso permit direccion-red mascara-red
  • Establecer traducción dinámica, especificando la lista de acceso definida anteriormente:
    1
    
    Router1(config)# ip nat inside source list numero-access-list pool nombre-pool-direcciones
  • Marcar una interfaz como conectada al interior:
    1
    
    Router1(config-if)# ip nat inside
  • Marcar una interfaz como conectada al exterior:
    1
    
    Router1(config-if)# ip nat outside
  • Mostrar las traducciones NAT:
    1
    
    Router1# show ip nat translations
  • Mostrar la información acerca del número total de traducciones NAT activas:
    1
    
    Router1# show ip nat statistics
  • Borrar todas las entradas de traducciones NAT dinámicas de la tabla de traducciones NAT:
    1
    
    Router1# clear ip nat translation*

 

 

DHCP

 

  • Especificar la dirección IP que el servidor DHCP no debería asignar a los clientes DHCP:
    1
    
    Router1(config)# ip dhcp excluded-address desde-dirección hasta-dirección
  • Crear un pool de direcciones DHCP con el nombre especificado y poner el router en el modo de configuración DHCP:
    1
    
    Router1(config)# ip dhcp pool nombre-pool
  • Definir el rango de direcciones DHCP disponibles:
    1
    
    Router1(dhcp-config)# network direccion-red prefijo-de-red
  • Definir la puerta de enlace por defecto o el router para uso de los clientes DHCP (normalmente la puerta de enlace suele ser la interfaz LAN del router):
    1
    
    Router1(dhcp-config)# default-router dirección1 direccion2 ...
  • Definir el nombre de dominio:
    1
    
    Router1(dhcp-config)# domain-name nombre-dominio-elegido
  • Definir la duración del préstamo DHCP. La duración por defecto es 1 dia:
    1
    
    Router1(dhcp-config)# lease {dias [horas [minutos]] |infinite}
  • Visualizar múltiples pools DHCP, sumarizar la información de pool DHCP:
    1
    
    Router1# show ip dhcp pool
  • Mostrar todos los conflictos de direcciones grabados por el servidor DHCP:
    1
    
    Router1# show ip dhcp conflict

 

 

Configurar TELNET

 

  • 1
    
    Router1(config)# line console 
  • 1
    
    Router1(config-line)# password micontraseña
  • 1
    
    Router1(config-line)# login
  • 1
    
    Router1(config-line)# exit
  • 1
    
    Router1(config)# line vty  4
  • 1
    
    Router1(config-line)# password micontraseña2
  • 1
    
    Router1(config-line)# login
  • 1
    
    Router1(config-line)# exit

 

 

Comandos FTP

 

Copiar configuración FTP al Servidor FTP

 

  • Para copiar por FTP (en este caso vamos a copiar la running-config del router):
1
copy ftp run
  • A continuación nos pedirá la IP o el hostname del servidor FTP donde deseamos copiar el archivo:
1
miservidorftp.com
  • Nos pedirá introducir el nombre de archivo (o pulsamos enter y lo dejamos por defecto)
1
miarchivoftp
  • A continuación ya podemos revisar que en el servidor FTP se ha copiado el archivo (en Packet tracer lo revisamos en la pestaña de configuración de FTP)

 

Copiar archivos desde un cliente FTP al servidor FTP

 

  • Conectar por ftp al servidor ftp:
    1
    
    ftp miservidorftp.com
  • Introducimos ahora los datos de login FTP (usuario y password)
  • Copiar un archivo por FTP al servidor FTP:
    1
    
    put miarchivo.txt
  • Listar los archivos FTP del directorio FTP remoto:
    1
    
    dir
  • Copiar un archivo FTP desde el servidor FTP al cliente FTP:
    1
    
    get miarchivo.txt
  • Renombrar archivo por FTP:
    1
    
    rename miarchivo.txt renombrado.txt
  • Borrar archivos por FTP:
    1
    
    delete renombrado.txt
  • Salir de la sesión FTP:
    1
    
    quit

 

 

Comandos de depuración de errores en router Cisco

 

Estos son algunos de los comandos más útiles para hacer Debug o depuración de errores en routers cisco:

 

  • Habilitar debug para RIP:
    1
    
    Router#debug ip rip
  • (aparecerá el mensaje: RIP protocol debugging is on)

  • Habilitar info de depuración resumida para IGRP:
    1
    
    debug ip igrp events
  • Habilitar info detallada de depuración IGRP
    1
    
    debug ip igrp transactions
  • Depuración de IPX RIP
    1
    
    debug ipx routing activity
  • Depurar IPX SAP
    1
    
    debug IPX SAP
  • Habilitar depuración para CHAP o PAP
    1
    
    debug ppp authentication
  • Desactivar toda depuración
    1
    
    no debug all
    1
    
    undebug all

 

 

Verificación de estado y posibles errores

 

  • Verificar el estado y funcionamiento de un puerto o interfaz, incluyendo su ip:
    1
    
    Router1#show ip interface brief

 
Hemos visto una gran cantidad de comandos cisco para routers, sobre todo los más comunes y utilizados.  

Esperamos que te sean de ayuda.

 




Etiquetas del articulo: , , ,